Netsweeper is pleased to announce the release of Netsweeper 9.2.3 EA for early adopters. The 9.2.3 release is feature complete with Organization Path Enforcement, Menu Promotion, Progressive Web App Support and major improvements to the Simple Group Manager. This allows for the Simple Group Manager to be used as a parent portal for education when combined with the new Policy Service core feature for multi-Organization Policy Processing.
All customers should start to upgrade their test environments to the Netsweeper 9.2.3 and plan for production environment upgrades where the new features are critical to meet business requirements. Netsweeper expects the 9.2.4 release to be GA and released at the end of November 2026.
If you have any questions or concerns about planning an upgrade to this release, please contact Netsweeper Technical Support (support@netsweeper.com).
See Also
9.2 Features and Improvements (Work in progress)
Download
To download the latest release, please use the following link:
https://repo.netsweeper.com/releases/centos/iso/netsweeper-el8-x86_64-9.2.3-1.iso (9.2.3 md5 checksum) (9.2.3 sha256 signature)
Changelog 9.2.3
| Issue Type | Ticket | Summary |
|---|---|---|
| Improvement | NS-1240 | Added the ability to parse the QUIC IETF protocol and handle the different 'CONNECTIONS' inside the QUIC protocol in the NSEF library. |
| Improvement | NS-1241 | Added the ability to use the QUIC IETF connection close message to close a QUIC stream. |
| New Feature | NS-2530 | Added the ability for the Policy Service to log original Policy Request input information as well as the output logging info, allowing the ability to see the request username and other info along with the final logged info, enabling Policy Service replay. |
| Bug | NS-2804 | Client Dynamic Updates could still output an error message when the Policy Service was stopped. |
| Improvement | NS-2813 | Renamed the 'Allow All' and 'Deny All' functions to 'Browse Mode' in the Simple Group Manager. |
| Bug | NS-2814 | The Quick Report count was not being restricted to only Quick Reports. |
| Bug | NS-2815 | Quick Reports are now able to be enabled and disabled on per-Organization basis, through the WebAdmin and via APIs. |
| Improvement | NS-2832 | The Manage Reports popup would omit Report names when the Daily Report Interval was disabled and Daily Reports were unavailable or did not exist. |
| Bug | NS-2833 | Performing an export in the Accounts window's Manage Groups tab would result in a partial export. The tab did not have our Advanced Filter function or the ability to select individual Groups in the table, further reducing Export functionaity. |
| New Feature | NS-2840 | Added the ability to disable a shared Template in a Child Organization that will disable it in that Organization as well as all children to that Organization. |
| Bug | NS-2842 | Using the Dashboard's quick search would always redirect to the Groups window, even for Accounts that only had permission for the 'Simple Groups' window. |
| Bug | NS-2843 | We no longer display the 'Customize Reports' button or empty Report selection field for Accounts that can't see or select any reports in the Home Dashboard. |
| Bug | NS-2846 | The 'Expiry Date' column did not display Time and Year info in the Groups window's List tab. |
| Improvement | NS-2856 | The Simple Group window now supports Category Template editing with the mobile UI. |
| New Feature | NS-2857 | The Profile Manager now supports the Organization path changes for the WebAdmin, allowing /organame/webadmin/clientlogin parsing for the First Time Login Process. |
| Improvement | NS-2871 | The Simple Groups Profile tab's radio button selection would reset and stop displaying the active profile after refreshing the page or navigating away from the tab. |
| Improvement | NS-2891 | Replaced the 'Assume Identity' Account information banner has been replaced with a new icon. Hovering over the icon will display the Account info as pop-up text. |
| Bug | NS-2901 | When importing Clients, we now force the lastchange column to be set to 'now', ensuring the timestamp is accurately set to the time of the import. |
| Improvement | NS-2904 | Added Selectize support to the Organisation filter in Demand Reports. |
| Improvement | NS-2905 | The Create Report Templates for Scheduled and Demand Reports would not display if there were per-Group limits set for the Reports. |
| Bug | NS-2906 | Request Logs export will now only export columns that are being displayed at the time of the export. |
| Improvement | NS-2907 | We have optimized the Reporter Service Report selection for improved database performance. |
| Bug | NS-2908 | Accounts with the Manage All Groups Permission would not get static filters for Reports without a dynamic filter when a Group limit per Reports is enforced and a Group count limit for Reports was not set. |
| Improvement | NS-2909 | WebAdmin Log messages are now truncated to fit into the database when they are over the text field's 64kbyte limit. |
| Bug | NS-2910 | Editing Global Quick Reports from the Scheduled Reports where the Owner field was empty would show the wrong Report Definition, including Child Organizations and Child Organization Groups. |
| Improvement | NS-2913 | Deleting Groups in the Root Organization would take a long time for deployments with a large amount of Reports. |
| Bug | NS-2915 | Importing Services after exporting Services in the Administration > Services window would cause all Service types to be erased. |
| Bug | NS-2916 | The fix_org_ids.php script would hardcode database names instead of using values from settings. |
| Improvement | NS-2917 | Menu Promotion in 9.2.2 did not allow an onGuard only user to view the WebAdmin to Logout, since when there is only one menu item we use this as the dashboard. |
| Bug | NS-2919 | The 9.1.12 release would fail to get the Directory Sync version and would always display a clock skew error for all servers. |
| Bug | NS-2921 | An overly restrictive inner-join in a Report's Owner field could result in a user being incorrectly denied access to the Report. |
| Bug | NS-2922 | Resolved an issue with auth_redirect.orgid column not existing when upgrading Deny Pages. |
| New Feature | NS-2925 | Added a Theme tab to the Organization window. Accounts with the 'Modify Organization Details' Permission will be able to access it and modify the Organization's Theme images. |
| New Feature | NS-2926 | Added an 'End User License Agreeement' section to WebAdmin Settings that allows a EULA to be set and enabled for Accounts and Signups. |
| Bug | NS-2927 | The 'Email all Accounts' function will once again use the 'BCC' method instead of the 'To' by default, addressing a regression the initial change caused in the 9.1 release cycle. |
| Improvement | NS-2928 | Improved Organization Path Enforcement, we now allow Theme Editor to change all images in the 9.2 release, improving the per-Organization enforcement and ensuring unauthenticated pages use the appropriate Organization settings. |
| Improvement | NS-2929 | Added the ability to theme and change the Sidebar-Menu image. |
| Bug | NS-2930 | The Agent 'Add Name Based Client' configuration option would always return an empty error message. |
| Improvement | NS-2932 | Optimized the Workstation Agent configuration lookup for improved database performance. |
| Bug | NS-2933 | Due to changes in our Organizational structure, Admin users in the Root Organization were no longer able to see all Agent Configs, this has been restored to ensure backward compatability. |
| Bug | NS-2934 | We would fail to filter the data when a SysOp Account would use the Search tool in the Directory Sync window, for objects that were manually assigned to the Account. |
| Bug | NS-2937 | SysOp Accounts creating a Directory Sync Search Base would append the Account's Organization instead of the Active Organization. |
| Bug | NS-2940 | Users were unable to modify the CC and BCC fields for Reports. |
| Bug | NS-2941 | Resolved a rare issue where the Reporter Service could fail to generate a Report with a 500 Internal Server error. |
| Improvement | NS-2942 | The Simple Groups Reset Group Profile will now use the Group's Image icon. |
| New Feature | NS-2944 | The Policy Service and Capture Module now have the ability to filter DNS queries and block qtype=65, allowing us to deny DNS in Out of Band deployments, such as telcos. |
| Bug | NS-2945 | SysOps creating Agent Configs would append the Account's Organization instead of the Active Organization, causing issues with appending to Client and Group names. |
| Improvement | NS-2947 | The Search tab in the Demand Reports > Create Report window would not display if there were per-Group limits set for the Reports. |
| Improvement | NS-2948 | The Quick tab in the Demand Reports > Create Report window would not display if there were per-Group limits set for the Reports. |
| Bug | NS-2950 | The Workstation Agent would errantly create Clients in Root Organization when the WebAdmin setting 'Use @orgname in Client Name for Organizations' was enabled. |
| Bug | NS-2951 | Agent Configs in the Root Organization were unable to append to Group and Client names, due to the character used to represent the Root Organization being considered invalid. |
| Bug | NS-2952 | The WebAdmin Settings for specific Organizations were not always loaded and enforced. |
| Bug | NS-2953 | The Agent did not load the WebAdmin Settings from the Organization that the Agent Config belonged to. |
| Bug | NS-2968 | Resolved an issue where the 'Create Template' popup would fail to render correctly, resulting in an unusable popup interface. |
| New Feature | NS-2976 | WebAdmin Settings for 'WebAdmin Login Settings' now support per-Organization settings and Organizational path enforcement. |
| Bug | NS-2979 | WAgent logout would fail for Clients in Restricted Organizations, as the OrgID would get passed to client_dynamic_delete via the wrong argument. |
| Improvement | NS-2980 | WAgent Groups created by envcreate will now belong to the Agent Config's Organization, not the Root Organization. |
| Bug | NS-2988 | NSup2D did not process failure-based return codes from php modules properly. |
| Bug | NS-2994 | Category Template export could produce an empty file (JSON/CSV) when exporting filtered, all, or selected entries. |
| Improvement | NS-2996 | We have removed the security labels from the default database, ending the unnecessary prompt that had occured in the 8.2.6 and above releases. |
Copyright © 2026 Netsweeper Inc. All rights reserved.
Confidential and Private information. Distribution of the information contained herein is strictly prohibited.